GNOME Software does not install third-party .deb packages

As we know Ubuntu 16.04 LTS was released on April 21, 2016. Ubuntu Software Center has been replaced by GNOME Software Center due to few long time issues still remain, such as more resource usage & slowness on application.

There will be a bug on GNOME Software Center which will not allow users to install software packages in the .deb file format obtained from third-party sources such as Google Chrome, Opera, Dropbox, MEGA Sync Client, etc..

This was happen only for Third-party source software and it’s working fine for Ubuntu repository packages.

Many users faced the issue and added the bug to launchpad page to track further.

Canonical Confirmed the bug on April 21, 2016 because the bug affects multiple users. Finally Canonical pushed the fix to base repository on April 28, 2016 (Canonical took more then a week to push the patch).

Post navigation